Welcome, Guest! Why not create a free forum account today and join in with the world's friendliest bunch of Kindle enthusiasts

Help. Manual software update failing for 4th gen Kindle on version 4.0

Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Offline Jonean02
29 May 2018, 03:16 PM | Post: #1

Junior Member

Posts: 1
Joined: May 2018

Thanked 0 times

Help. Manual software update failing for 4th gen Kindle on version 4.0

Hi all Kindle users. Some help would be appreciated on my issue. Thanks in advance for any replies.
Got my wife’s kindle out and found it has been so long hidden that it wouldn’t connect to Wifi. Found the router but wouldn’t connect using my WiFi password. I assumed it has been so long in the bedroom drawer that it was a software update issue (currently on version 4.0). I connected the kindle to my PC, found it as a drive and searched amazon for the latest software. Down loaded and tried everything I found from 4.1 onwards and every time I dropped it from my C:\ to the kindle it copied across but didn’t even give me an option in settings to 'Update Kindle' when I disconnected. The only version that showed me the 'Update Kindle' option was the very latest version but that fails when I tried the update, presumably because it needs previous software versions first to build on.

I’m at the end of my tether now. I’m loathed to throw this in the bin and buy a new one as it seems such a waste of a great reader, so any ideas on 1) how I can update the software manually successfully and 2) connect to the Wifi would be greatly appreciated.

Thanks in advance.